epiphany-extensions (2.30.2-1) debian-dir only changes

Summary

 debian/README                   |    3 
 debian/changelog                |  648 ++++++++++++++++++++++++++++++++++++++++
 debian/compat                   |    1 
 debian/control                  |   42 ++
 debian/control.in               |   37 ++
 debian/copyright                |   27 +
 debian/epiphany-extensions.docs |    1 
 debian/rules                    |   20 +
 debian/watch                    |    2 
 9 files changed, 781 insertions(+)

    
download this patch

Patch contents

--- epiphany-extensions-2.30.2.orig/debian/changelog
+++ epiphany-extensions-2.30.2/debian/changelog
@@ -0,0 +1,648 @@
+epiphany-extensions (2.30.2-1) unstable; urgency=low
+
+  [ Josselin Mouette ]
+  * Drop obsolete dependencies on w3c-dtd-xhtml and sgml-data.
+
+  [ Sebastian Dröge ]
+  * New upstream bugfix release:
+    + debian/patches/01_fix_html5tube.patch:
+      - Dropped, merged upstream.
+
+ -- Sebastian Dröge <slomo@debian.org>  Sun, 05 Sep 2010 12:23:22 +0200
+
+epiphany-extensions (2.30.1-2) unstable; urgency=low
+
+  * debian/patches/01_fix_html5tube.patch:
+  - patch from upstream to make html5tube work with the recent
+    changes to youtube's video page
+
+ -- Gustavo Noronha Silva <kov@debian.org>  Thu, 05 Aug 2010 20:05:16 -0300
+
+epiphany-extensions (2.30.1-1) unstable; urgency=low
+
+  * New upstream bugfix release.
+
+ -- Sebastian Dröge <slomo@debian.org>  Wed, 12 May 2010 12:54:40 +0200
+
+epiphany-extensions (2.30.0-4) unstable; urgency=low
+
+  * debian/control.in:
+    + (Build-) depend on epiphany-browser >= 2.30.2 for the new
+      and finally correct extensions directory.
+
+ -- Sebastian Dröge <slomo@debian.org>  Fri, 09 Apr 2010 07:34:35 +0200
+
+epiphany-extensions (2.30.0-3) unstable; urgency=low
+
+  * debian/control.in:
+    - Build-Depends: epiphany-browser-dev (>= 2.30.0).
+    - Depends: epiphany-browser (>= 2.30.0).
+
+ -- David Weinehall <tao@debian.org>  Mon, 05 Apr 2010 13:39:25 +0300
+
+epiphany-extensions (2.30.0-2) unstable; urgency=low
+
+  * debian/control.in:
+    - Build-Depends: libgtk2.0-dev (>= 2.19.5).
+
+ -- David Weinehall <tao@debian.org>  Sun, 04 Apr 2010 22:24:28 +0300
+
+epiphany-extensions (2.30.0-1) unstable; urgency=low
+
+  * New upstream stable release:
+    + debian/patches/adblock.patch:
+      - Dropped, merged upstream.
+
+ -- David Weinehall <tao@debian.org>  Thu, 01 Apr 2010 10:26:25 +0300
+
+epiphany-extensions (2.29.91-2) unstable; urgency=low
+
+  * Added a patch for Bugzilla: #599562.
+    (Fixes some false positives in the adblock plugin).
+  * debian/control.in:
+    - Bump Standards version to 3.8.4 (No changes needed).
+    - Added myself to Uploaders.
+
+ -- David Weinehall <tao@debian.org>  Sun, 07 Mar 2010 19:30:30 +0200
+
+epiphany-extensions (2.29.91-1) unstable; urgency=low
+
+  * New upstream release:
+    + debian/patches/01_doc_build.patch:
+      - Dropped, file exists now.
+    + debian/control.in:
+      - Remove glade from build dependencies.
+
+ -- Sebastian Dröge <slomo@debian.org>  Sat, 27 Feb 2010 13:08:27 +0100
+
+epiphany-extensions (2.29.6-2) unstable; urgency=low
+
+  * Re-enable gestures extension. Closes: #567568.
+  * 01_doc_build.patch: new patch. Fix a Makefile that references a 
+    non-existant file.
+
+ -- Josselin Mouette <joss@debian.org>  Sat, 30 Jan 2010 16:42:19 +0100
+
+epiphany-extensions (2.29.6-1) unstable; urgency=low
+
+  * New upstream release:
+    + debian/control.in:
+      - (Build-) depend on epiphany-browser >= 2.29.6.
+
+ -- Sebastian Dröge <slomo@debian.org>  Fri, 29 Jan 2010 11:01:30 +0100
+
+epiphany-extensions (2.29.0~20092012-1) unstable; urgency=low
+
+  * New upstream GIT snapshot:
+    + debian/patches/01_epiphany-2.29.patch,
+      debian/patches/02_disable-sidebar.patch:
+      - Dropped, merged upstream.
+    + debian/control.in:
+      - (Build-) depend on epiphany-browser >= 2.29.5.
+
+ -- Sebastian Dröge <slomo@debian.org>  Wed, 13 Jan 2010 10:47:40 +0100
+
+epiphany-extensions (2.28.1-2) unstable; urgency=low
+
+  * debian/control.in,
+    debian/patches/01_epiphany-2.29.patch:
+    + Rebuild against epiphany 2.29.1.
+  * debian/patches/02_disable-sidebar.patch:
+    + Disable sidebar extension for now, porting it is not trivial.
+
+ -- Sebastian Dröge <slomo@debian.org>  Fri, 06 Nov 2009 10:32:51 +0100
+
+epiphany-extensions (2.28.1-1) unstable; urgency=low
+
+  * New upstream bugfix release.
+
+ -- Sebastian Dröge <slomo@debian.org>  Tue, 20 Oct 2009 08:16:41 +0200
+
+epiphany-extensions (2.28.0-1) unstable; urgency=low
+
+  [ Josselin Mouette ]
+  * Only require python-gconf instead of python-gnome2. Closes: #541588.
+
+  [ Sebastian Dröge ]
+  * New upstream stable release:
+    + debian/rules,
+      debian/control.in,
+      debian/pyversions,
+      debian/webkit-extensions:
+      - Update everything for WebKit.
+    + debian/patches/01_missing_picture.patch:
+      - Dropped, not needed anymore.
+
+ -- Sebastian Dröge <slomo@debian.org>  Fri, 25 Sep 2009 07:34:19 +0200
+
+epiphany-extensions (2.26.1-1) unstable; urgency=low
+
+  * Require python 2.5 and drop elementtree requirement. 
+    Closes: #524381.
+  * New upstream release.
+  * Bump epiphany requirement.
+  * Update licensing information in copyright.
+  * 01_missing_picture.patch: new patch. Match a file removal in the 
+    makefile.
+
+ -- Josselin Mouette <joss@debian.org>  Wed, 06 May 2009 16:43:44 +0200
+
+epiphany-extensions (2.24.3-1) unstable; urgency=low
+
+  * New upstream translation and bugfix release.
+
+ -- Josselin Mouette <joss@debian.org>  Sun, 08 Mar 2009 19:57:39 +0100
+
+epiphany-extensions (2.24.1-1) experimental; urgency=low
+
+  * New upstream release.
+  * Wrap dependencies.
+  * Update (build-)dependencies on epiphany-gecko to 2.24.
+  * Standards version is 3.8.0.
+
+ -- Josselin Mouette <joss@debian.org>  Fri, 14 Nov 2008 01:48:12 +0100
+
+epiphany-extensions (2.22.2-1) unstable; urgency=low
+
+  * Upload to unstable; drop check-dist include.
+  * Bump dependencies to epiphany 2.22 and xulrunner 1.9~rc1.
+  * New upstream release.
+
+ -- Josselin Mouette <joss@debian.org>  Sun, 08 Jun 2008 22:14:06 +0200
+
+epiphany-extensions (2.22.1-4) experimental; urgency=low
+
+  * Depend on xulrunner-dev instead of -dev-static. Closes: #478157.
+
+ -- Josselin Mouette <joss@debian.org>  Mon, 28 Apr 2008 10:50:08 +0200
+
+epiphany-extensions (2.22.1-3) experimental; urgency=low
+
+  * Build against xulrunner-dev-static.
+  * Require 1.9~b5-3 so that it builds correctly.
+  * Use the libxul version, apparently upstream requires this crap to be 
+    *statically linked* in *each extension*.
+  * Require epiphany 2.22.1.1-2.
+
+ -- Josselin Mouette <joss@debian.org>  Sun, 20 Apr 2008 13:44:13 +0200
+
+epiphany-extensions (2.22.1-2) unstable; urgency=low
+
+  * debian/webkit-extensions: list extensions that are known to be 
+    working with epiphany-webkit.
+  * debian/rules: add symbolic links for them in the epiphany-webkit 
+    directory. We'll probably stick to this ugly hack until webkit 
+    becomes the only supported engine, at which point most extensions 
+    will have been rewritten.
+
+ -- Josselin Mouette <joss@debian.org>  Thu, 17 Apr 2008 22:40:01 +0200
+
+epiphany-extensions (2.22.1-1) unstable; urgency=low
+
+  [ Sam Morris ]
+  * New upstream release.
+  * Build-depend on libgconf2-dev.
+  * Build-depend on epiphany-browser-dev 2.22.0. 
+
+  [ Josselin Mouette ]
+  * Upload to unstable; drop check-dist include.
+
+ -- Josselin Mouette <joss@debian.org>  Thu, 17 Apr 2008 21:18:04 +0200
+
+epiphany-extensions (2.21.0~svn1675-1) experimental; urgency=low
+
+  [ Sam Morris ]
+  * Build-depend on epiphany-browser-dev 2.21.
+  * Builds with GCC 4.3 (closes: #456053).
+  * Typo in help file fixed (closes: #443961).
+
+  [ Josselin Mouette ]
+  * Wrap build-depends.
+  * New upstream SVN snapshot.
+  * Update build-dependencies accordingly.
+  * Upload to experimental; include check-dist makefile.
+
+ -- Josselin Mouette <joss@debian.org>  Tue, 19 Feb 2008 21:26:02 +0100
+
+epiphany-extensions (2.20.3-1) unstable; urgency=low
+
+  * rules: don't ship the .la files.
+  * New upstream release.
+  * delicious.diff: removed, integrated upstream.
+  * Standards version is 3.7.3.
+
+ -- Josselin Mouette <joss@debian.org>  Sat, 12 Jan 2008 03:07:46 +0100
+
+epiphany-extensions (2.20.1-2) unstable; urgency=low
+
+  * delicious.diff: stolen from upstream SVN; workaround for a browser
+    freeze. Closes: #448685.
+
+ -- Josselin Mouette <joss@debian.org>  Thu, 15 Nov 2007 20:58:42 +0100
+
+epiphany-extensions (2.20.1-1) unstable; urgency=low
+
+  [ Sam Morris ]
+  * Require python-gtk2 2.12 because the Creative Commons licence viewer
+    extension uses the new gtk.EventBox.set_tooltip_text method.
+  * Patch debian/control.in as well, and require only python-gtk2 2.11
+    as well.
+  * Build-depend on python-gtk2 since the autoconf script checks for it.
+  * Oops, the .pc file is contained in python-gtk2-dev, so build-depend on
+    that instead.
+
+  [ Sebastian Dröge ]
+  * New upstream bugfix release.
+
+ -- Sebastian Dröge <slomo@debian.org>  Fri, 02 Nov 2007 05:43:49 +0100
+
+epiphany-extensions (2.20.0-1) unstable; urgency=low
+
+  * New upstream release.
+    + Use --enable-gecko.
+  * Depend on epiphany-gecko, not epiphany-browser.
+  * 01_download_dir.patch: removed, obsoleted by improvements in the
+    epiphany patch.
+  * 50_fr-po.patch: removed, merged upstream.
+  * Enable livehttpheaders and permissions extensions.
+
+ -- Josselin Mouette <joss@debian.org>  Fri, 21 Sep 2007 17:55:37 +0200
+
+epiphany-extensions (2.18.1-2) unstable; urgency=low
+
+  * Upload to unstable, drop check-dist include.
+  * Update to debhelper compat level 5.
+
+ -- Sebastian Dröge <slomo@debian.org>  Wed, 25 Apr 2007 06:12:19 +0200
+
+epiphany-extensions (2.18.1-1) experimental; urgency=low
+
+  * New upstream release.
+    - Drop patch 30_dont-dist-epilicious and 31_epilicious-import-warning,
+      merged upstream.
+
+ -- Loic Minier <lool@dooz.org>  Mon, 09 Apr 2007 16:10:39 +0200
+
+epiphany-extensions (2.18.0-4) UNRELEASED; urgency=low
+
+  * Depend on python-elementtree (closes: #415554).
+  * Remove the hardcoded call to dh_pysupport in the 2.14 directory.
+
+ -- Josselin Mouette <joss@debian.org>  Wed, 28 Mar 2007 00:25:17 +0200
+
+epiphany-extensions (2.18.0-3) experimental; urgency=low
+
+  * Merge 2.14.1.1-2 and 2.14.1.1-3; SVN r6503:9094.
+    - Stay without a libosp-dev build-dep; no idea why it was removed, no
+      idea why it was added.
+
+ -- Loic Minier <lool@dooz.org>  Sun, 18 Mar 2007 19:08:56 +0100
+
+epiphany-extensions (2.18.0-2) experimental; urgency=low
+
+  * New patch, 30_dont-dist-epilicious, stop disting epilicious.py, it's
+    generated on build; Backported from SVN r1472; GNOME #418041;
+    closes: #414780.
+  * New patch, 31_epilicious-import-warning, fixes warning during
+    byte-compilation; GNOME #418164; closes:  #414743.
+
+ -- Loic Minier <lool@dooz.org>  Wed, 14 Mar 2007 11:38:13 +0100
+
+epiphany-extensions (2.18.0-1) experimental; urgency=low
+
+  [ Sam Morris ]
+  * New upstream release.
+  * Build-depend on epiphany-browser-dev 2.18.
+  * Build-depend on gconf2 so that gconftool-2 is available during
+    configuration.
+  * adblock extension is now build by default; remove from configure flags.
+  * Build the new epilicious extension.
+  * No need to remove /var in binary-post-install rule since scrollkeeper is
+    disabled in configure
+
+  [ Loic Minier ]
+  * Include the new check-dist Makefile to prevent accidental uploads to
+    unstable; bump build-dep on gnome-pkg-tools to >= 0.10.
+  * Include CDBS's utils.
+
+ -- Loic Minier <lool@dooz.org>  Mon, 12 Mar 2007 16:13:53 +0100
+
+epiphany-extensions (2.16.1-2) experimental; urgency=low
+
+  [ Loic Minier ]
+  * Add a get-orig-source target to retrieve the upstream tarball.
+  * Set pyversions to 2.3-.
+  * Build-depend on python (>= 2.3).
+  * Add ${misc:Depends}.
+
+  [ Josselin Mouette ]
+  * 01_download_dir.patch: remove the distinction between download and
+    save directory, following the change in epiphany.
+
+  [ Loic Minier ]
+  * Build-depend on librsvg2-common >= 2.16.0-2 for autobuildability.
+
+ -- Loic Minier <lool@dooz.org>  Mon, 12 Mar 2007 15:09:52 +0100
+
+epiphany-extensions (2.16.1-1) experimental; urgency=low
+
+  * New upstream release (closes: #406235).
+  * Use --disable-scrollkeeper.
+
+ -- Josselin Mouette <joss@debian.org>  Thu, 11 Jan 2007 23:34:52 +0100
+
+epiphany-extensions (2.16.0-1) experimental; urgency=low
+
+  [ Loic Minier ]
+  * Add watch file.
+
+  [ Josselin Mouette ]
+  * New upstream release.
+  * Rebuild against epiphany 2.16.
+  * Change maintainer to please Jordi.
+  * Depend on epiphany-browser (<< 2.17) to avoid the need for a
+    conflict in the future.
+  * Build-depend on intltool 0.35.0.
+  * Remove build-dep on libgnomeui-dev.
+  * Bump build-dependencies on glib and gtk.
+  * Build-depend on python-support 0.4 and call it.
+  * Include gnome-version.mk and build-depend on gnome-pkg-tools 0.6.
+    + Use ${gnome:Version} for dependencies.
+    + Use it to search for the correct directory in dh_pysupport call.
+
+ -- Josselin Mouette <joss@debian.org>  Sat,  9 Sep 2006 21:36:48 +0200
+
+epiphany-extensions (2.14.1.1-3) unstable; urgency=low
+
+  * New patch, 50_fr-po, updates for the translation into French; thanks
+    Cyril Brulebois; closes: #408716
+
+ -- Loic Minier <lool@dooz.org>  Sun, 28 Jan 2007 09:23:14 +0100
+
+epiphany-extensions (2.14.1.1-2) unstable; urgency=high
+
+  * Urgency high for RC bugfix.
+  * Depend on ${python:Depends} and ${misc:Depends}.
+  * Convert to new Python Policy.
+    - Build-depend on python-support (>= 0.4)
+    - Bump up python build-dep to >= 2.3.
+    - Set pyversions to 2.3-.
+    - Call dh_pysupport on /usr/lib/epiphany/2.14/extensions.
+    - Does not ship *.pyc and *.pyo files; closes: #394179.
+  * Add watch file.
+  * Add a get-orig-source target to retrieve the upstream tarball.
+  * Disable scrollkeeper installation via --disable-scrollkeeper.
+
+ -- Loic Minier <lool@dooz.org>  Mon, 15 Jan 2007 11:47:25 +0100
+
+epiphany-extensions (2.14.1.1-1) unstable; urgency=low
+
+  * New upstream release.
+    - Drop tabsmenu from DEB_CONFIGURE_EXTRA_FLAGS as it was removed upstream.
+      [debian/rules]
+  * Bump up Standards-Version to 3.7.2.
+    [debian/control, debian/control.in]
+
+ -- Loic Minier <lool@dooz.org>  Sat,  3 Jun 2006 11:46:42 +0200
+
+epiphany-extensions (2.14.1-2) unstable; urgency=low
+
+  [ Josselin Mouette ]
+  * Suggest epiphany-extension-gwget (closes: #360838).
+
+  [ Jordi Mallach ]
+  * Depend on python-gnome2, as it's needed by the console and favicon
+    extensions.
+
+ -- Jordi Mallach <jordi@debian.org>  Sat, 27 May 2006 14:39:55 +0200
+
+epiphany-extensions (2.14.1-1) unstable; urgency=low
+
+  [ Jordi Mallach ]
+  * New upstream release.
+    - fixes input blocking when using gestures (closes: #363684).
+
+  [ Josselin Mouette ]
+  * debian/control.in: add gnome-doc-utils (>= 0.3.2) to Build-Depends.
+  * Also add scrollkeeper.
+  * debian/rules: include debhelper.mk before gnome.mk.
+  * debian/rules: clean /var in post-install target.
+
+ -- Josselin Mouette <joss@debian.org>  Tue, 25 Apr 2006 23:46:09 +0200
+
+epiphany-extensions (2.14.0.1-1) unstable; urgency=low
+
+  * New upstream release.
+    - builds with GCC 4.1 (closes: #357483).
+    - the AdBlock extension is back (closes: #341258, again).
+  * debian/rules: if a MS Windows volume is found, try to build against the
+    Internet Explorer Extension Developer Kit, for better standards support.
+  * debian/control.in:
+    - update build-depends as per configure.ac
+    - update epiphany runtime dependency to 2.14.
+    - sync descriptions with Ubuntu.
+  * debian/rules: add adblock, remove net-monitor.
+
+ -- Jordi Mallach <jordi@debian.org>  Sat,  1 Apr 2006 13:09:03 +0200
+
+epiphany-extensions (1.8.2-5) unstable; urgency=low
+
+  * Apply patch from Mike Hommey to build against libxul-dev (closes: #351984).
+    - debian/control.in:
+      + Changed Build-deps from mozilla-browser to libxul-dev.
+      + Changed dependencies and conflicts accordingly.
+    - debian/rules: Add --with-mozilla=xulrunner to the configure line.
+  * debian/control.in: bump epiphany-browser dependency to >= 1.8.5, first
+    version using libxul.
+
+ -- Jordi Mallach <jordi@debian.org>  Mon, 20 Feb 2006 19:48:31 +0100
+
+epiphany-extensions (1.8.2-4) unstable; urgency=low
+
+  * The "Popups" release.
+  * debian/rules: disable adblock, as it's been causing way too much noise
+    on both the BTS and Bugzilla. It will only be back with GNOME 2.14
+    (closes: #352899, #352850).
+  * debian/control.in: build-depend on epiphany-browser-dev (>= 1.8-3-4),
+    to ensure python extensions are built (closes: #352235).
+
+ -- Jordi Mallach <jordi@debian.org>  Fri, 17 Feb 2006 22:37:27 +0100
+
+epiphany-extensions (1.8.2-3) unstable; urgency=low
+
+  * Try the unstable thing again...
+
+ -- Jordi Mallach <jordi@debian.org>  Tue, 10 Jan 2006 14:45:36 +0100
+
+epiphany-extensions (1.8.2-2) experimental; urgency=low
+
+  * Upload to unstable.
+  * Please note the adblock extension is a bit unstable for this release.
+
+ -- Jordi Mallach <jordi@debian.org>  Tue, 10 Jan 2006 11:34:13 +0100
+
+epiphany-extensions (1.8.2-1) experimental; urgency=low
+
+  * New upstream release.
+  * debian/rules: enable adblock extension (closes: #341258).
+  * debian/control.in: add adblock to description.
+
+ -- Jordi Mallach <jordi@debian.org>  Sun,  4 Dec 2005 21:13:32 +0100
+
+epiphany-extensions (1.8.1-1) experimental; urgency=low
+
+  * New upstream version.
+  * debian/control.in:
+    - updated the epiphany-browser requirement.
+    - updated the Standards-Version.
+
+ -- Sebastien Bacher <seb128@debian.org>  Tue, 25 Oct 2005 10:32:00 +0200
+
+epiphany-extensions (1.8.0-1) experimental; urgency=low
+
+  * New upstream release
+
+ -- Sjoerd Simons <sjoerd@debian.org>  Thu,  8 Sep 2005 11:31:59 +0200
+
+epiphany-extensions (1.6.4-2) unstable; urgency=low
+
+  * Bump libosp-dev Build-Dep to 1.5.1.0-2.1 for the C++ transition
+    (closes: #321314).
+
+ -- Loic Minier <lool@dooz.org>  Mon,  8 Aug 2005 22:04:31 +0200
+
+epiphany-extensions (1.6.4-1) unstable; urgency=low
+
+  * New upstream release.
+
+ -- Jordi Mallach <jordi@debian.org>  Thu,  7 Jul 2005 20:05:00 +0200
+
+epiphany-extensions (1.6.3-1) unstable; urgency=low
+
+  * New upstream release.
+  * Upload to unstable.
+  * debian/control.in: build-depend on epiphany-browser-dev (>= 1.6.0)
+    (closes: #309542).
+  * debian/patches/01_gcc40_signedness.patch: removed, applied upstream.
+  * A sidebar extension is included (closes: #216604).
+
+ -- Jordi Mallach <jordi@debian.org>  Wed,  8 Jun 2005 00:33:23 +0200
+
+epiphany-extensions (1.6.2-3) experimental; urgency=low
+
+  * debian/patches/01_gcc40_signedness.patch:
+    - fix the patch.
+
+ -- Sebastien Bacher <seb128@debian.org>  Thu, 14 Apr 2005 18:24:29 +0200
+
+epiphany-extensions (1.6.2-2) experimental; urgency=low
+
+  * debian/patches/01_gcc40_signedness.patch:
+    - updated, fix the build with gcc4.
+
+ -- Sebastien Bacher <seb128@debian.org>  Thu, 14 Apr 2005 18:01:42 +0200
+
+epiphany-extensions (1.6.2-1) experimental; urgency=low
+
+  * New upstream version.
+  * debian/control.in:
+    - updated requirements.
+  * debian/patches/01_gcc40_signedness.patch:
+    - fixed with the new version.
+  * debian/rules:
+    - updated the list of options to build.
+
+ -- Sebastien Bacher <seb128@debian.org>  Thu, 14 Apr 2005 16:58:08 +0200
+
+epiphany-extensions (1.4.5-1) unstable; urgency=low
+
+  * The "London Calling" release.
+  * New upstream release.
+  * debian/patches/01_gcc40_signedness.patch: patch from Andreas Jochens,
+    with modifications by Christian Persch to fix compilation on amd64
+    using gcc-4.0 (closes: #290309).
+
+ -- Jordi Mallach <jordi@debian.org>  Wed,  9 Mar 2005 02:28:01 +0100
+
+epiphany-extensions (1.4.4-1) unstable; urgency=low
+
+  * New upstream release.
+  * debian/control.in: require epiphany >= 1.4.6.
+
+ -- Jordi Mallach <jordi@debian.org>  Sun, 26 Dec 2004 01:36:48 +0100
+
+epiphany-extensions (1.4.3-1) unstable; urgency=low
+
+  * New upstream release.
+
+ -- Jordi Mallach <jordi@debian.org>  Thu,  9 Dec 2004 19:32:28 +0100
+
+epiphany-extensions (1.4.2-2) unstable; urgency=low
+
+  * Upload to unstable.
+  * debian/control.in:
+    + set myself as Maintainer.
+    + remove build-dep on libc6-dev.
+
+ -- Jordi Mallach <jordi@debian.org>  Sun, 21 Nov 2004 02:10:08 +0100
+
+epiphany-extensions (1.4.2-1) experimental; urgency=low
+
+  * GNOME team upload.
+  * New upstream release.
+  * debian/control.in:
+    - require epiphany-browser-dev 1.4.1 and update a few other
+      dependencies to match configure.ac requirements.
+    - tweak description to match new extensions.
+  * debian/rules: configure with --with-extensions=all.
+
+ -- Jordi Mallach <jordi@debian.org>  Wed, 13 Oct 2004 02:04:58 +0200
+
+epiphany-extensions (1.0-1) unstable; urgency=low
+
+  * New upstream release.
+  * Require epiphany-browser-dev 1.2.7. 
+  * Add --with-mozilla-snapshot=branch1.7 configure flag.
+
+ -- Edd Dumbill <ejad@debian.org>  Fri,  6 Aug 2004 01:14:14 +0100
+
+epiphany-extensions (0.9.1-2) unstable; urgency=low
+
+  * Rebuild against Mozilla 1.7.  Tighten Mozilla deps.
+
+ -- Edd Dumbill <ejad@debian.org>  Fri, 25 Jun 2004 10:03:31 +0100
+
+epiphany-extensions (0.9.1-1) unstable; urgency=low
+
+  * New upstream release.
+  * Update build-dep to epiphany-browser-dev 1.2.6 or better.
+
+ -- Edd Dumbill <ejad@debian.org>  Mon, 14 Jun 2004 15:19:36 +0100
+
+epiphany-extensions (0.8.2-2) unstable; urgency=low
+
+  * Upload to unstable.  (Closes: #205250)
+  * Add gnome-pkg-tools to build-dep. (Closes: #244590)
+
+ -- Edd Dumbill <ejad@debian.org>  Wed,  2 Jun 2004 11:30:25 +0100
+
+epiphany-extensions (0.8.2-1) experimental; urgency=low
+
+  * New upstream.
+
+ -- Edd Dumbill <ejad@debian.org>  Tue, 13 Apr 2004 21:31:01 +0100
+
+epiphany-extensions (0.8.1-2) experimental; urgency=low
+
+  * Add missing gnome-pkg-tools build-dep.
+  * Disable inclusion of .la files.
+  * Add build-deps for libosp-dev and deps on w3c-xhtml-dtd and sgml-data.
+    This improves the experience of the error checker.
+
+ -- Edd Dumbill <ejad@debian.org>  Tue, 13 Apr 2004 11:52:52 +0100
+
+epiphany-extensions (0.8.1-1) experimental; urgency=low
+
+  * Initial packaging.
+
+ -- Edd Dumbill <ejad@debian.org>  Tue, 13 Apr 2004 09:44:17 +0100
--- epiphany-extensions-2.30.2.orig/debian/watch
+++ epiphany-extensions-2.30.2/debian/watch
@@ -0,0 +1,2 @@
+version=2
+http://ftp.gnome.org/pub/gnome/sources/epiphany-extensions/([\d\.]+)[02468]/epiphany-extensions-([\d\.]+)\.tar\.gz
--- epiphany-extensions-2.30.2.orig/debian/README
+++ epiphany-extensions-2.30.2/debian/README
@@ -0,0 +1,3 @@
+Documentation is somewhat incomplete for these extensions.
+See http://gnome.org/projects/epiphany/extensions.html for more
+information.
--- epiphany-extensions-2.30.2.orig/debian/epiphany-extensions.docs
+++ epiphany-extensions-2.30.2/debian/epiphany-extensions.docs
@@ -0,0 +1 @@
+NEWS
--- epiphany-extensions-2.30.2.orig/debian/control.in
+++ epiphany-extensions-2.30.2/debian/control.in
@@ -0,0 +1,37 @@
+Source: epiphany-extensions
+Section: gnome
+Priority: optional
+Maintainer: Josselin Mouette <joss@debian.org>
+Uploaders: @GNOME_TEAM@
+Build-Depends: cdbs (>= 0.4.17),
+               debhelper (>= 5),
+               gnome-pkg-tools (>= 0.10),
+               gconf2,
+               libgconf2-dev,
+               libxml-parser-perl,
+               intltool (>= 0.35.0),
+               gnome-doc-utils (>= 0.3.2),
+               epiphany-browser-dev (>= 2.30.2),
+               libxml2-dev (>= 2.6.0),
+               libglib2.0-dev (>= 2.15.5),
+               libgtk2.0-dev (>= 2.19.5),
+               libosp-dev,
+               libdbus-glib-1-dev ( >= 0.60),
+               libwebkit-dev,
+               scrollkeeper
+Standards-Version: 3.8.4
+
+Package: epiphany-extensions
+Architecture: any
+Depends: ${misc:Depends},
+         ${shlibs:Depends},
+         epiphany-browser (>= 2.30.2),
+         epiphany-browser (<< 2.31)
+Suggests: epiphany-extension-gwget
+Description: Extensions for Epiphany web browser
+ Adds extra features to GNOME's Epiphany web browser, including action,
+ adblocking, auto-reload, auto-scroller, console, extensions manager, find,
+ greasemonkey, javaconsole, mouse gestures, move tabs between windows,
+ python-console, pushscroller, rss extension, error viewer and validator,
+ certificate viewer, sidebar, smart bookmarks, page info, CSS Stylesheet,
+ favicon.ico, tab states and a GNOME Dashboard interface.
--- epiphany-extensions-2.30.2.orig/debian/copyright
+++ epiphany-extensions-2.30.2/debian/copyright
@@ -0,0 +1,27 @@
+Debianized by Edd Dumbill from tarball available at
+http://gnome.org/projects/epiphany/extensions.html on 2004/04/13. 
+
+Upstream authors:
+	Marco Pesenti Gritti <marco@it.gnome.org>
+	Adam Hooper <adamh@cvs.gnome.org>
+	Christian Persch <chpe@gnome.org>
+	Lee Willis
+
+License:
+
+   This program is free software; you can redistribute it and/or modify
+   it under the terms of the GNU General Public License as published by
+   the Free Software Foundation; either version 2 of the License, or
+   (at your option) any later version.
+
+   This program is distributed in the hope that it will be useful,
+   but WITHOUT ANY WARRANTY; without even the implied warranty of
+   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+   GNU General Public License for more details.
+
+   You should have received a copy of the GNU General Public License
+   along with this package; if not, write to the Free Software
+   Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301 USA
+
+On Debian GNU/Linux systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL-2'.
--- epiphany-extensions-2.30.2.orig/debian/control
+++ epiphany-extensions-2.30.2/debian/control
@@ -0,0 +1,42 @@
+# This file is autogenerated. DO NOT EDIT!
+# 
+# Modifications should be made to debian/control.in instead.
+# This file is regenerated automatically in the clean target.
+
+Source: epiphany-extensions
+Section: gnome
+Priority: optional
+Maintainer: Josselin Mouette <joss@debian.org>
+Uploaders: David Weinehall <tao@debian.org>, Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>, Gustavo Noronha Silva <kov@debian.org>, Sebastian Dröge <slomo@debian.org>
+Build-Depends: cdbs (>= 0.4.17),
+               debhelper (>= 5),
+               gnome-pkg-tools (>= 0.10),
+               gconf2,
+               libgconf2-dev,
+               libxml-parser-perl,
+               intltool (>= 0.35.0),
+               gnome-doc-utils (>= 0.3.2),
+               epiphany-browser-dev (>= 2.30.2),
+               libxml2-dev (>= 2.6.0),
+               libglib2.0-dev (>= 2.15.5),
+               libgtk2.0-dev (>= 2.19.5),
+               libosp-dev,
+               libdbus-glib-1-dev ( >= 0.60),
+               libwebkit-dev,
+               scrollkeeper
+Standards-Version: 3.8.4
+
+Package: epiphany-extensions
+Architecture: any
+Depends: ${misc:Depends},
+         ${shlibs:Depends},
+         epiphany-browser (>= 2.30.2),
+         epiphany-browser (<< 2.31)
+Suggests: epiphany-extension-gwget
+Description: Extensions for Epiphany web browser
+ Adds extra features to GNOME's Epiphany web browser, including action,
+ adblocking, auto-reload, auto-scroller, console, extensions manager, find,
+ greasemonkey, javaconsole, mouse gestures, move tabs between windows,
+ python-console, pushscroller, rss extension, error viewer and validator,
+ certificate viewer, sidebar, smart bookmarks, page info, CSS Stylesheet,
+ favicon.ico, tab states and a GNOME Dashboard interface.
--- epiphany-extensions-2.30.2.orig/debian/rules
+++ epiphany-extensions-2.30.2/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+include /usr/share/cdbs/1/rules/buildcore.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/gnome.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/utils.mk
+include /usr/share/gnome-pkg-tools/1/rules/uploaders.mk
+include /usr/share/gnome-pkg-tools/1/rules/gnome-version.mk
+-include /usr/share/gnome-pkg-tools/1/rules/gnome-get-source.mk
+
+DEB_CONFIGURE_EXTRA_FLAGS += --disable-static \
+	--with-extensions=all,gestures,greasemonkey,rss,permissions \
+	--disable-scrollkeeper --disable-maintainer-mode
+
+binary-post-install/epiphany-extensions::
+	rm -f debian/epiphany-extensions/usr/lib/epiphany-*/*/*/*.la
+
+clean::
+	rm -f po/.intltool-merge-cache
+	rm -f intltool-extract intltool-update intltool-merge
--- epiphany-extensions-2.30.2.orig/debian/compat
+++ epiphany-extensions-2.30.2/debian/compat
@@ -0,0 +1 @@
+5