alsa-plugins (1.0.27-2) use_libavutil.patch

Summary

 a52/pcm_a52.c |    1 +
 configure.in  |    2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

    
download this patch

Patch contents

Author: Jordi Mallach <jordi@debian.org>
Description: Check for and include libavutil.h to avoid unresolved symbols.
 The a52 plugin uses av_free(), but does not check for libavutil
 availability. Patch configure.in to check for the module, and include
 libavutil.h.
 .
 The patch needs to be extended to do proper checks for avutil header files.
Forwarded: no

Index: alsa-plugins-1.0.27/configure.in
===================================================================
--- alsa-plugins-1.0.27.orig/configure.in	2013-04-26 23:02:22.144794780 +0200
+++ alsa-plugins-1.0.27/configure.in	2013-04-26 23:02:22.140794782 +0200
@@ -67,7 +67,7 @@
       AS_HELP_STRING([--disable-avcodec], [Don't build plugins depending on avcodec (a52)]))
 
 if test "x$enable_avcodec" != "xno"; then
-  PKG_CHECK_MODULES(AVCODEC, [libavcodec], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
+  PKG_CHECK_MODULES(AVCODEC, [libavcodec libavutil], [HAVE_AVCODEC=yes], [HAVE_AVCODEC=no])
 fi
 
 if test "x$HAVE_AVCODEC" = "xno"; then
Index: alsa-plugins-1.0.27/a52/pcm_a52.c
===================================================================
--- alsa-plugins-1.0.27.orig/a52/pcm_a52.c	2013-04-26 23:02:22.144794780 +0200
+++ alsa-plugins-1.0.27/a52/pcm_a52.c	2013-04-26 23:02:22.140794782 +0200
@@ -26,6 +26,7 @@
 #include <alsa/pcm_external.h>
 #include <alsa/pcm_plugin.h>
 #include AVCODEC_HEADER
+#include <libavutil/avutil.h>
 
 #if LIBAVCODEC_VERSION_MAJOR >= 53 && LIBAVCODEC_VERSION_MINOR >= 34
 #include <libavutil/audioconvert.h>