freeplane (1.1.3-2) 15_libraries_manifest.patch

Summary

 freeplane/META-INF/MANIFEST.MF               |   10 ++++----
 freeplane_plugin_help/META-INF/MANIFEST.MF   |    2 -
 freeplane_plugin_latex/META-INF/MANIFEST.MF  |    2 -
 freeplane_plugin_script/META-INF/MANIFEST.MF |    2 -
 freeplane_plugin_svg/META-INF/MANIFEST.MF    |   33 ++++++++-------------------
 5 files changed, 18 insertions(+), 31 deletions(-)

    
download this patch

Patch contents

--- a/freeplane/META-INF/MANIFEST.MF
+++ b/freeplane/META-INF/MANIFEST.MF
@@ -7,11 +7,11 @@
  lib/freeplaneeditor.jar,
  lib/freeplanemac.jar,
  lib/freeplaneosgi.jar,
- lib/commons-lang-2.0.jar,
- lib/forms-1.0.5.jar,
- lib/gnu-regexp-1.1.4.jar,
- lib/SimplyHTML.jar,
- lib/jortho.jar
+ ../../../java/commons-lang.jar,
+ ../../../java/forms.jar,
+ ../../../java/gnu-regexp-1.1.4.jar,
+ ../../../java/SimplyHTML.jar,
+ ../../../java/jortho.jar
 Bundle-Activator: org.freeplane.main.osgi.Activator
 Import-Package: org.osgi.framework
 Export-Package: org.apache.commons.lang,
--- a/freeplane_plugin_help/META-INF/MANIFEST.MF
+++ b/freeplane_plugin_help/META-INF/MANIFEST.MF
@@ -8,5 +8,5 @@
 Bundle-RequiredExecutionEnvironment: J2SE-1.5
 Require-Bundle: org.freeplane.core;bundle-version="1.0.1"
 Bundle-ClassPath: lib/plugin.jar,
- lib/jhall.jar
+ ../../../java/jhall.jar
 Export-Package: org.freeplane.plugin.help;uses:="org.freeplane.core.ui,org.freeplane.core.controller,org.osgi.framework"
--- a/freeplane_plugin_latex/META-INF/MANIFEST.MF
+++ b/freeplane_plugin_latex/META-INF/MANIFEST.MF
@@ -7,5 +7,5 @@
 Import-Package: org.osgi.framework;version="1.3.0"
 Bundle-RequiredExecutionEnvironment: J2SE-1.5
 Require-Bundle: org.freeplane.core;bundle-version="1.0.1"
-Bundle-ClassPath: lib/jlatexmath.jar,
+Bundle-ClassPath: ../../../java/jlatexmath.jar,
  lib/plugin.jar
--- a/freeplane_plugin_script/META-INF/MANIFEST.MF
+++ b/freeplane_plugin_script/META-INF/MANIFEST.MF
@@ -7,5 +7,5 @@
 Import-Package: org.osgi.framework;version="1.3.0"
 Bundle-RequiredExecutionEnvironment: J2SE-1.5
 Require-Bundle: org.freeplane.core;bundle-version="1.0.1"
-Bundle-ClassPath: lib/groovy-all-1.5.6.jar,
+Bundle-ClassPath: ../../../java/groovy-all.jar,
  lib/plugin.jar
--- a/freeplane_plugin_svg/META-INF/MANIFEST.MF
+++ b/freeplane_plugin_svg/META-INF/MANIFEST.MF
@@ -7,27 +7,14 @@
 Import-Package: org.osgi.framework;version="1.3.0"
 Bundle-RequiredExecutionEnvironment: J2SE-1.5
 Require-Bundle: org.freeplane.core;bundle-version="1.0.1"
-Bundle-ClassPath: lib/batik-awt-util.jar,
- lib/batik-bridge.jar,
- lib/batik-css.jar,
- lib/batik-dom.jar,
- lib/batik-ext.jar,
- lib/batik-extension.jar,
- lib/batik-gui-util.jar,
- lib/batik-gvt.jar,
- lib/batik-parser.jar,
- lib/batik-script.jar,
- lib/batik-anim.jar,
- lib/batik-codec.jar,
- lib/batik-svg-dom.jar,
- lib/batik-svggen.jar,
- lib/batik-swing.jar,
- lib/batik-transcoder.jar,
- lib/batik-util.jar,
- lib/batik-xml.jar,
- lib/js.jar,
- lib/pdf-transcoder.jar,
- lib/xerces_2_5_0.jar,
- lib/xml-apis.jar,
+Bundle-ClassPath: ../../../java/batik-all.jar,
+ ../../../java/js.jar,
+ ../../../java/fop.jar,
+ ../../../java/avalon-framework.jar,
+ ../../../java/commons-logging.jar,
+ ../../../java/commons-io.jar,
+ ../../../java/xmlgraphics-commons.jar,
+ ../../../java/xercesImpl.jar,
+ ../../../java/xml-apis.jar,
  lib/plugin.jar,
- lib/xml-apis-ext.jar
+ ../../../java/xml-apis-ext.jar