geany-plugins (0.19-1) 99_ltmain_as-needed.patch

Summary

 ltmain.sh |   14 ++++++++++++++
 1 file changed, 14 insertions(+)

    
download this patch

Patch contents

# Description: Fix ltmain.sh to handle -Wl,--as-needed properly
# Origin: vendor
# Forwarded: not-needed
--- a/ltmain.sh.old	2007-10-09 07:38:25.000000000 +0200
+++ a/ltmain.sh	2007-10-09 07:39:25.000000000 +0200
@@ -1794,6 +1794,11 @@
 	arg=`$echo "X$arg" | $Xsed -e "s/^ //"`
 	;;
 
+      -Wl,--as-needed)
+	deplibs="$deplibs $arg"
+	continue
+	;;
+
       -Wl,*)
 	args=`$echo "X$arg" | $Xsed -e "$sed_quote_subst" -e 's/^-Wl,//'`
 	arg=
@@ -2137,6 +2142,15 @@
 	lib=
 	found=no
 	case $deplib in
+	-Wl,--as-needed)
+	  if test "$linkmode,$pass" = "prog,link"; then
+	    compile_deplibs="$deplib $compile_deplibs"
+	    finalize_deplibs="$deplib $finalize_deplibs"
+	  else
+	    deplibs="$deplib $deplibs"
+	  fi
+	  continue
+	  ;;
 	-mt|-mthreads|-kthread|-Kthread|-pthread|-pthreads|--thread-safe|-threads)
 	  if test "$linkmode,$pass" = "prog,link"; then
 	    compile_deplibs="$deplib $compile_deplibs"