geany-plugins (0.21.1.dfsg-4) 0001-build-Add-gmodule-2.0-to-geanylua-dependencies.patch

Summary

 build/geanylua.m4 |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

    
download this patch

Patch contents

From 0db3fa978542dc63baadd0d8a68a19b454497469 Mon Sep 17 00:00:00 2001
From: Chow Loong Jin <hyperair@debian.org>
Date: Sat, 18 Feb 2012 22:51:37 +0800
Subject: [PATCH] build: Add gmodule-2.0 to geanylua dependencies

-lgmodule-2.0 from gmodule-2.0.pc is required in order to prevent linking errors
in Ubuntu 12.04.
---
 build/geanylua.m4 |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/build/geanylua.m4 b/build/geanylua.m4
index af280b7..a7df908 100644
--- a/build/geanylua.m4
+++ b/build/geanylua.m4
@@ -15,7 +15,7 @@ AC_DEFUN([GP_CHECK_GEANYLUA],
 
     LUA_VERSION=5.1
     GP_CHECK_PLUGIN_DEPS([GeanyLua], [LUA],
-                         [${LUA_PKG_NAME} >= ${LUA_VERSION}])
+                         [${LUA_PKG_NAME} >= ${LUA_VERSION} gmodule-2.0])
     GP_STATUS_PLUGIN_ADD([GeanyLua], [$enable_geanylua])
 
     AC_CONFIG_FILES([
-- 
1.7.5.4