libhighline-ruby (1.5.2-1) 02_remove-rubygems-require.patch

Summary

 examples/ansi_colors.rb       |    2 +-
 examples/asking_for_arrays.rb |    2 +-
 examples/basic_usage.rb       |    2 +-
 examples/menus.rb             |    2 +-
 examples/page_and_wrap.rb     |    2 +-
 examples/password.rb          |    2 +-
 examples/trapping_eof.rb      |    2 +-
 examples/using_readline.rb    |    2 +-
 8 files changed, 8 insertions(+), 8 deletions(-)

    
download this patch

Patch contents

diff -Nur -x '*.orig' -x '*~' trunk/examples/ansi_colors.rb trunk.new/examples/ansi_colors.rb
--- trunk/examples/ansi_colors.rb	2009-05-09 23:50:01.000000000 -0700
+++ trunk.new/examples/ansi_colors.rb	2009-05-09 23:50:01.000000000 -0700
@@ -5,7 +5,7 @@
 #  Created by James Edward Gray II on 2005-05-03.
 #  Copyright 2005 Gray Productions. All rights reserved.
 
-require "rubygems"
+# require "rubygems"    # Uncomment if using Rubygems
 require "highline/import"
 
 # Supported color sequences.
diff -Nur -x '*.orig' -x '*~' trunk/examples/asking_for_arrays.rb trunk.new/examples/asking_for_arrays.rb
--- trunk/examples/asking_for_arrays.rb	2009-05-09 23:50:01.000000000 -0700
+++ trunk.new/examples/asking_for_arrays.rb	2009-05-09 23:50:01.000000000 -0700
@@ -5,7 +5,7 @@
 #  Created by James Edward Gray II on 2005-07-05.
 #  Copyright 2005 Gray Productions. All rights reserved.
 
-require "rubygems"
+# require "rubygems"    # Uncomment if using Rubygems
 require "highline/import"
 require "pp"
 
diff -Nur -x '*.orig' -x '*~' trunk/examples/basic_usage.rb trunk.new/examples/basic_usage.rb
--- trunk/examples/basic_usage.rb	2009-05-09 23:50:01.000000000 -0700
+++ trunk.new/examples/basic_usage.rb	2009-05-09 23:50:01.000000000 -0700
@@ -5,7 +5,7 @@
 #  Created by James Edward Gray II on 2005-04-28.
 #  Copyright 2005 Gray Productions. All rights reserved.
 
-require "rubygems"
+# require "rubygems"    # Uncomment if using Rubygems
 require "highline/import"
 require "yaml"
 
diff -Nur -x '*.orig' -x '*~' trunk/examples/menus.rb trunk.new/examples/menus.rb
--- trunk/examples/menus.rb	2009-05-09 23:50:01.000000000 -0700
+++ trunk.new/examples/menus.rb	2009-05-09 23:50:01.000000000 -0700
@@ -1,6 +1,6 @@
 #!/usr/bin/ruby -w
 
-require "rubygems"
+# require "rubygems"    # Uncomment if using Rubygems
 require "highline/import"
 
 # The old way, using ask() and say()...
diff -Nur -x '*.orig' -x '*~' trunk/examples/page_and_wrap.rb trunk.new/examples/page_and_wrap.rb
--- trunk/examples/page_and_wrap.rb	2009-05-09 23:50:01.000000000 -0700
+++ trunk.new/examples/page_and_wrap.rb	2009-05-09 23:50:01.000000000 -0700
@@ -5,7 +5,7 @@
 #  Created by James Edward Gray II on 2005-05-07.
 #  Copyright 2005 Gray Productions. All rights reserved.
 
-require "rubygems"
+# require "rubygems"    # Uncomment if using Rubygems
 require "highline/import"
 
 $terminal.wrap_at = 80
diff -Nur -x '*.orig' -x '*~' trunk/examples/password.rb trunk.new/examples/password.rb
--- trunk/examples/password.rb	2009-05-09 23:50:01.000000000 -0700
+++ trunk.new/examples/password.rb	2009-05-09 23:50:01.000000000 -0700
@@ -1,6 +1,6 @@
 #!/usr/bin/ruby -w
 
-require "rubygems"
+# require "rubygems"    # Uncomment if using Rubygems
 require "highline/import"
 
 pass = ask("Enter your password:  ") { |q| q.echo = false }
diff -Nur -x '*.orig' -x '*~' trunk/examples/trapping_eof.rb trunk.new/examples/trapping_eof.rb
--- trunk/examples/trapping_eof.rb	2009-05-09 23:50:01.000000000 -0700
+++ trunk.new/examples/trapping_eof.rb	2009-05-09 23:50:01.000000000 -0700
@@ -5,7 +5,7 @@
 #  Created by James Edward Gray II on 2006-02-20.
 #  Copyright 2006 Gray Productions. All rights reserved.
 
-require "rubygems"
+# require "rubygems"    # Uncomment if using Rubygems
 require "highline/import"
 
 loop do
diff -Nur -x '*.orig' -x '*~' trunk/examples/using_readline.rb trunk.new/examples/using_readline.rb
--- trunk/examples/using_readline.rb	2009-05-09 23:50:01.000000000 -0700
+++ trunk.new/examples/using_readline.rb	2009-05-09 23:50:01.000000000 -0700
@@ -5,7 +5,7 @@
 #  Created by James Edward Gray II on 2005-07-06.
 #  Copyright 2005 Gray Productions. All rights reserved.
 
-require "rubygems"
+# require "rubygems"    # Uncomment if using Rubygems
 require "highline/import"
 
 loop do