pdfmod (0.8.3-1) 0003-Make-POPPLER_SHARP_DLL_CONFIG-conditional.patch

Summary

 src/Makefile.am |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

    
download this patch

Patch contents

From 8c111956f38867765ce083ca669707ace6d2c171 Mon Sep 17 00:00:00 2001
From: Chow Loong Jin <hyperair@ubuntu.com>
Date: Fri, 18 Jun 2010 04:25:58 +0800
Subject: [PATCH 3/3] Make POPPLER_SHARP_DLL_CONFIG conditional

Only add POPPLER_SHARP_DLL_CONFIG to PROGRAMFILES if USE_BUNDLED_POPPLER
is true, as it should be copied from the external installation
otherwise.

Signed-off-by: Gabriel Burt <gabriel.burt@gmail.com>
---
 src/Makefile.am |    6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/Makefile.am b/src/Makefile.am
index 892373f..797e2bb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,9 +16,7 @@ PDFMOD_EXE_MDB_SOURCE=../bin/PdfMod.exe.mdb
 AL=al2
 SATELLITE_ASSEMBLY_NAME=$(notdir $(basename $(ASSEMBLY))).resources.dll
 
-PROGRAMFILES = \
-	$(PDFMOD_EXE_MDB) \
-	$(POPPLER_SHARP_DLL_CONFIG)
+PROGRAMFILES = $(PDFMOD_EXE_MDB)
 
 BINARIES = \
 	$(PDFMOD)  
@@ -72,6 +70,8 @@ REFERENCES =  \
 
 if USE_BUNDLED_POPPLER
 PROJECT_REFERENCES += ../bin/poppler-sharp.dll
+PROGRAMFILES += $(POPPLER_SHARP_DLL_CONFIG)
+
 else
 REFERENCES += -pkg:poppler-sharp
 endif
-- 
1.7.0.4