tclcl (1.20-6) package_require_rm_exact.diff

Summary

 Makefile.in |    4 ++++
 1 file changed, 4 insertions(+)

    
download this patch

Patch contents

Description: remove -exact from package require for tcl and tk
 Debian is using strict libraries version policy (ie: tcl 8.5/8.6)
 so, the exact is not needed here.
Bug: http://mailman.isi.edu/pipermail/ns-users/2011-June/070597.html
Author: YunQiang Su <wzssyqa@gmail.com>
Last-Update: 2011-06-30
Index: tclcl/Makefile.in
===================================================================
--- tclcl.orig/Makefile.in	2011-06-30 20:02:36.405690862 +0800
+++ tclcl/Makefile.in	2011-06-30 20:03:41.870015477 +0800
@@ -169,10 +169,14 @@
 embedded-tcl.cc: $(TCL_LIBRARY_FILES) $(TCL2C)
 	$(RM) $@
 	$(TCL2C) et_tcl $(TCL_LIBRARY_FILES) > $@
+	sed -i -e "s/package require -exact Tk/package require Tk/g" $@
+	sed -i -e "s/package require -exact Tcl/package require Tcl/g" $@
 
 embedded-tk.cc: $(TK_LIBRARY_FILES) $(TCL2C)
 	$(RM) $@
 	$(TCL2C) et_tk $(TK_LIBRARY_FILES) > $@
+	sed -i -e "s/package require -exact Tk/package require Tk/g" $@
+	sed -i -e "s/package require -exact Tcl/package require Tcl/g" $@
 
 embedded-tclobj.cc: tcl-object.tcl tcl-import.tcl tcl-http.tcl $(TCL2C)
 	$(RM) $@